Android P Mungkin Tidak Menyokong Aplikasi Android 4.1 Dan Sebelumnya

Android P Mungkin Tidak Menyokong Aplikasi Android 4.1 Dan Sebelumnya

Diterbitkan pada Mac 19, 2018 oleh .

Google sebelum ini telah membuat beberapa perubahan dari segi sokongan untuk aplikasi lama dari segi tahap API dan sebagainya. Kini, bergerak kehadapan, Android P akan datang kelak akan memerlukan tahap API 17 dan terkini untuk sokongan aplikasi – yang mana merupakan tahap API yang hadir bersama Android 4.2.

Langkah perubahan ini sekaligus membuatkan aplikasi yang dibangunkan untuk Android 4.1 dan sebelumnya tidak lagi akan disokong pada Android P. Buat masa ini, ia tidak diketahui lagi sama ada Google akan membuat halangan penuh untuk aplikasi berkaitan – atau sekadar memberikan amaran dan mengehadkan aksesnya sahaja.

Bagi para pembangun, anda dinasihatkan untuk mengoptimasikan aplikasi anda untuk versi terkini Android P. Bagi pengguna pula, anda dinasihatkan menggunakan aplikasi dengan sokongan Android terkini untuk memastikan ia menyertakan pelbagai integrasi sekuriti semasa dan lebih dioptimasikan dari segi penggunaan tenaga dan sebagainya.


TIPS & ULASAN